Southeast Center - Annex and Main 3rd Floor Connectivity Issues

Incident Report for Delaware County Community College

Resolved

This incident has been resolved.
Posted Jan 27, 2026 - 09:26 EST

Investigating

We are currently investigating network connectivity issues at Southeast Center Annex Third Floor and certain areas of the Third Floor in the Main Building. We will provide more information as it becomes available.
Posted Jan 22, 2026 - 10:45 EST
This incident affected: Network Services and Wireless Connectivity.