Power outage at Southeast Center
Incident Report for DCCC
Resolved
This incident has been resolved.
Posted Apr 19, 2019 - 07:22 EDT
Update
PECO has revised it's repair timeline to be completed approximately at 5:00 am.
Posted Apr 19, 2019 - 01:10 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 18, 2019 - 20:07 EDT
Monitoring
PECO has reported a power outage affecting our Southeast Canter campus. Power is expected to be restored by 11: 20 p.m.
Posted Apr 18, 2019 - 20:07 EDT