Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 03, 2026 - 22:00 EST
Scheduled
As part of routine security maintenance, we will be replacing the wireless network certificate on February 3rd, 2026 at 10:00pm EST.
What this means for you: - After the certificate is replaced, personal devices (phones, tablets, laptops, etc.) may no longer automatically connect to the wireless network. When you next connect, you may be prompted to trust or accept the new wireless certificate. Please accept the prompt to restore connectivity.
What to expect: - A one-time certificate trust/acceptance prompt on personal device - No impact after the new certificate is trusted
If you do not trust the new certificate, your device will be unable to connect to the wireless network.
If you experience issues or do not see a prompt to trust the certificate, please contact the IT Support Center for assistance
IT Support Center 610-359-5211
Posted Feb 03, 2026 - 18:09 EST
This scheduled maintenance affected: Wireless Connectivity.