Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 28, 2025 - 16:00 EDT
Scheduled
Network services will be unavailable during this outage, including the following:
• Wireless Connectivity • Telephone • Internet • Printing • Network storage • Building Management Systems
Posted Mar 24, 2025 - 10:19 EDT
This scheduled maintenance affected: Google Apps (Google Apps Docs, Google Apps Calendar, Google Apps Gmail, Google Apps Drive, Google Apps Hangouts, Google Apps Sheets), Zoom (Zoom Video Webinars, Zoom Group Messaging, Zoom Meetings, Zoom Software), delaGATE, Canvas Learning Management System, dccc.edu Website, Online Student Registration, DegreeWorks Student Planning, Online Payments, Network Services, Microsoft 365 - Outlook/Teams/Sharepoint/OneDrive, Banner Applications for Employees, support.dccc.edu, and Duo 2-Step Authentication (Duo Security Core Authentication Service, Duo Security Push Delivery, Duo Security Admin Panel).