Student Registration - Authentication Errors
Incident Report for Delaware County Community College
Resolved
This issue has been fixed. All systems are operational.
Posted Feb 07, 2020 - 23:13 EST
Identified
Students are receiving an authentication error when attempting to access registration. We have identified the issue and are working on a resolution.
Posted Feb 07, 2020 - 22:39 EST
This incident affected: Online Student Registration.