Emergency Network Maintenance

Scheduled for Jul 24, 06:00 - 08:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 21, 2026 - 16:00 EDT

Scheduled

A third party vendor has issued a critical security patch which will be applied to several network devices during this window.

Affected Campuses: ALL INTERNAL AND EXTERNAL USERS

Service(s) Impacted (Administrative and Academic):

• DCCC website
• delaGATE and delaGATE accessed applications such as:

o Argos
o Banner 9
o BCM
o CampusLogic
o Canvas
o Career Coach
o Course Evaluations
o DegreeWorks
o Google Apps
o In-Person Tutoring Scheduling
o Library Databases
o NeoGov
o Office 365 Applications
o Online Tutoring
o Online Orientation
o Phone Directory
o Parchment
o SignalVine
o Sirsi
o Smarthinking
o Starfish
o Student Calendar
o Student Email
o Student Registration and Schedules
o Student Records and Bill Payment
o Support Center
o Transfer Check
o Zoom

• Communitarian website
• Cashnet
• Bomgar Remote Support
• EZ Proxy
• Zoom Workplace
• QLESS
• Building Management Systems
• On Campus Internet Access
• VPN services
• Wireless Access
• DUO 2 Step Verification

2. Banner Services:

• Banner INB/SSB
• BDM (Banner Document Management)
• MAPS (Form Fusion & Intellicheck)
• CAPPS printing and other Banner printing processes
• Direct Deposit
Posted Jul 21, 2026 - 15:59 EDT
This scheduled maintenance affects: delaGATE (delagate.dccc.edu), Canvas Learning Management System, dccc.edu (College Website), Online Student Registration, DegreeWorks Student Planning, Online Payments, Network Services, Wireless Connectivity, Telecommunications, Microsoft 365 - Outlook/Teams/Sharepoint/OneDrive, and Banner Applications for Employees.