Network File Services – Service Disruption

Incident Report for Delaware County Community College

Resolved

Network File Services – Resolved
A fix has been implemented. If your mapped drives are not yet showing, please take the following steps based on how you are connecting:

Onsite: Reboot your computer.
Remote/VPN: Disconnect from VPN, then reconnect.

If you continue to experience issues, contact the IT Support Center at 610-359-5211 or open a ticket at support.dccc.edu.
Posted Apr 26, 2026 - 21:02 EDT

Identified

Users are unable to access network file shares (P/S/T/U drives) onsite and remotely. Mapped drives may appear missing or return an error when accessed. We have identified the cause and are actively working on a resolution.
Posted Apr 26, 2026 - 18:18 EDT
This incident affected: Network Services.