Connect2Success Logins Are Inoperative

Incident Report for Delaware County Community College

Resolved

Connect2Success is now operational.
Posted Dec 04, 2025 - 20:33 EST

Update

Troubleshooting is still underway. This issue will be resolved as soon as possible.
Posted Dec 04, 2025 - 15:40 EST

Identified

The issue has been identified and we expect this to be operational by mid-afternoon today.
Posted Dec 04, 2025 - 12:36 EST
This incident affected: Connect2Success.