Intermittent Printing Issues

Incident Report for Delaware County Community College

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 16:07 EDT

Investigating

We are currently experiencing issues with printing. Our team is investigating the issue and expect to have it resolved in short order.

Thank you for your patience.
Posted Jul 22, 2026 - 14:18 EDT
This incident affected: Printing.