Southeast Center Site Down

Incident Report for Delaware County Community College

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 17:13 EDT

Investigating

Due to a localized power issue, Southeast Center will be down until the root cause can be resolved. All network related services including Internet, telecom, wireless, printing, and network file share will be unavailable until power is restored

No other sites are affected by this outage.
Posted Mar 27, 2026 - 14:33 EDT
This incident affected: Network Services, Wireless Connectivity, Telecommunications, and Printing.