delaGATE Portal Outage

Incident Report for Delaware County Community College

Monitoring

A fix has been implemented and we are currently monitoring. If you are still having issues, please contact the IT Support Center at 610-359-5211.
Posted Aug 28, 2026 - 14:41 EDT

Investigating

We are currently investigating an issue with logins to the college's delaGATE portal system. College apps that use delaGATE login such as Canvas, Banner 9, and Zoom can be accessed by going to https://login.dccc.edu/sso
Posted Aug 28, 2026 - 08:48 EDT
This incident affects: delaGATE (delagate.dccc.edu).