Microsoft O365 Service Issues

Incident Report for Delaware County Community College

Resolved

Microsoft has confirmed that the affected infrastructure has returned to a healthy state and is operating as expected.
Posted Jan 23, 2026 - 09:30 EST

Identified

Employees may be receiving a "451 4.3.2 temporary server issue" error message when attempting to send or receive email through Outlook.

Some of the impacted service functions include, but may not be limited to:
- Sending and receiving email through Exchange Online, including notification emails from Microsoft Viva Engage.

Microsoft is continuing to review what actions are required to restore the affected infrastructure to a heathy state and rebalance the service traffic to achieve recovery.
Posted Jan 22, 2026 - 16:25 EST
This incident affected: Microsoft 365 - Outlook/Teams/Sharepoint/OneDrive.