College Wide System Outage - Windows Servers and Computers
Incident Report for DCCC
Resolved
Technicians have completed mass restoration activities for Marple Campus, Downingtown Center, Pennocks Bridge Center, Southeast Center, and Upper Darby Center. If you experience a computer not functioning as expected, please open a support ticket at support.dccc.edu or call our IT Support team at 610-359-5211. We thank you for your continued patience during this unexpected outage.
Posted Jul 22, 2024 - 16:47 EDT
Update
Dayforce is now available.
Posted Jul 22, 2024 - 09:13 EDT
Update
The majority of Marple Campus academic and employee computer systems have been restored.

IT will have a team member at Pennock Bridge, Downingtown, Upper Darby, and Southeast Center on Monday morning to resolve issues with staff computers and then begin working on the remaining academic systems. It is estimated that all academic computers will be restored before classes begin at each branch location.

Students with laptop loaners who are receiving a blue screen should call the IT Support Center at 610-359-5211 or open a ticket at support.dccc.edu to arrange a repair or replacement. You may also come to the Marple Campus IT Support Center, located in Room 4274, for repair. No appointment is necessary.

If you have an employee laptop that is affected and you are located at the Marple Campus, you must bring it in person to Room 4274 for repair. The repair takes less than 10 minutes per machine.

How Do I Know If My Machine Is Impacted:
Your machine will show a blue screen with a sad face; it will boot loop where you cannot log in, or when you log in, you will see a 'Safe Mode' message with a black background. If you do not have any of these symptoms, you do not need to take any action.

If you have any questions or concerns, please contact the IT Support Center at 610-359-5211
Posted Jul 19, 2024 - 22:12 EDT
Update
We have developed a programmatic fix for all academic systems; however, it requires visiting each computer station individually. IT staff are currently working on restoring Academic systems at the Marple Campus.

Due to additional encryption on employee laptops, additional steps are required for recovery. If your machine is impacted by this issue (receiving a blue screen), additional information on how to get it restored will be forthcoming.

If your machine was powered off or disconnected from the internet before Friday at 12:09 a.m. and brought online or booted after Friday at 1:27 a.m., it is NOT impacted.

Please note that many vendors and cloud providers are also experiencing issues for the same reasons that the College was impacted.
Dayforce is also experiencing an outage that is preventing access to timecard entry and approval.
Finalsite Connect (Blackboard) was impacted and is now back online.
Posted Jul 19, 2024 - 15:25 EDT
Update
External access to all systems has been restored.
All production servers have been restored.
Marple Security Desk computers have been restored.
Posted Jul 19, 2024 - 11:53 EDT
Update
delaGATE is back online.
VPN access has been restored.
Posted Jul 19, 2024 - 10:20 EDT
Identified
We are currently experiencing system-wide outages due to a faulty update published this morning by our cyber security vendor, Crowdstrike, which is impacting all Windows computers and servers. The faulty update will cause a (Blue Screen) on the computer and possibly a boot loop where you cannot access the system.

The College uses a CrowdStike product to identify, detect, and respond to malicious software installed on all Windows systems. The DCCC IT Team is working to restore access as quickly as possible.

We will provide updates as they are available.

Scheduled maintenance is currently on hold.

More information about the CrowdStike issue can be found here:
https://www.bleepingcomputer.com/news/security/crowdstrike-update-crashes-windows-systems-causes-outages-worldwide/
Posted Jul 19, 2024 - 09:51 EDT
This incident affected: Google Apps (Google Apps Docs, Google Apps Calendar, Google Apps Gmail, Google Apps Drive, Google Apps Hangouts, Google Apps Sheets), Zoom (Zoom Video Webinars, Zoom Group Messaging, Zoom Meetings, Zoom Software), delaGATE, Canvas Learning Management System, dccc.edu Website, Online Student Registration, DegreeWorks Student Planning, Online Payments, Network Services, Wireless Connectivity, Telecommunications, Microsoft 365 - Outlook/Teams/Sharepoint/OneDrive, Banner Applications for Employees, support.dccc.edu, Printing, DocuSign, csWiki, Connect2Success, and Duo 2-Step Authentication (Duo Security Core Authentication Service, Duo Security Push Delivery, Duo Security Admin Panel).