Limited Connectivity at Upper Darby Center

Incident Report for Delaware County Community College

Resolved

The connectivity issue at the Upper Darby Center has been resolved. The problem was identified as a fiber bend.
Posted Nov 18, 2025 - 15:48 EST

Investigating

As of 10:00 a.m. today, the Upper Darby Center is experiencing limited network connectivity. This affects Internet browsing, access to cloud services (email, Zoom, Duo, Canvas, etc.) and access to network resources (shared drives, Banner, etc.)

Our fiber service provider has dispatched a crew and will soon be actively troubleshooting the issue. We will share an update as soon as we have more information or an estimated time to resolution.
Posted Nov 18, 2025 - 13:34 EST
This incident affected: Network Services.