Canvas Outage

Incident Report for Delaware County Community College

Monitoring

Canvas is back online and accessible to all users.

The Microsoft 365, Google, and Zoom integrations within Canvas are temporarily unavailable. Direct access to M365, Google Workspace, and Zoom outside of Canvas is unaffected.
Posted May 07, 2026 - 23:53 EDT

Identified

Canvas is currently unavailable. This is a platform-wide issue at Instructure (the company behind Canvas), affecting multiple institutions. Instructure is investigating. We do not yet have an ETA for restoration.
Posted May 07, 2026 - 16:49 EDT
This incident affects: Canvas Learning Management System.