Billing and Financial Aid information cannot be accessed.
Incident Report for DCCC
Resolved
This incident has been resolved.
Posted May 22, 2020 - 18:15 EDT
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 18:15 EDT
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 16:13 EDT
Update
We are continuing to investigate this issue.
Posted May 22, 2020 - 16:12 EDT
Investigating
This is related to server maintenance that is running longer than expected. These services should be restored shortly.
Posted May 22, 2020 - 16:11 EDT
This incident affected: delaGATE and Online Payments.