DegreeWorks partial loss of functionality after Chrome 83 upgrade
Incident Report for DCCC
Resolved
Closing this incident. Until we receive a fix you need to add notes via the Notes icon. If you need to modify or delete notes, or use the Petitions or GPA Calc tabs you need to use Firefox.
Posted May 22, 2020 - 13:01 EDT
Update
We are continuing to investigate this issue.
Posted May 20, 2020 - 13:20 EDT
Investigating
Chrome is in the process of pushing Version 83.0.4103.61. Once that upgrade is applied the Notes, Petitions and GPA Calc tabs do not function. If you only need to add Notes you can click on the Notes icon at the top center of the degree audit. Notes will also still appear in degree audits. As a workaround if you need to modify or delete Notes, or if you need to use the Petition or GPA Calc tabs you can use the Firefox browser until this issue is resolved.
Posted May 20, 2020 - 13:12 EDT
This incident affected: DegreeWorks Student Planning.