Pearson MyLabsPlus Issues
Incident Report for DCCC
Resolved
Pearson has resolved the technical issue that was impacting your course(s). We apologize for the issue and thank you for your patience
Posted Apr 09, 2019 - 11:00 EDT
Investigating
Please be advised Pearson View is experiencing connectivity issues. Pearson is aware and investigating
Posted Apr 09, 2019 - 10:04 EDT